Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-1240

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2006-1240
Last Modified 05 Sep 2008 05:01:23
Published 15 Mar 2006 12:06:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2006-1240

Summary

Buffer overflow in inet_server.cpp in (1) fb_inet_server and (2) fbserver in Firebird 1.5.2.4731 allows local users to gain privileges via a long value of the -p argument.

Vulnerable Systems

Application

  • Firebirdsql Firebird 1.5

  • Firebirdsql Firebird 1.5.1

  • Firebirdsql Firebird 1.5.2


References

BID - 17077

BUGTRAQ - 20060312 Buffer Overflow and Installation Script Error in Firebird 1.5.3

XF - firebird-fbinetserver-fbserver-bo(25282)


Last Updated: 27 May 2016 10:41:59