Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-1681

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2006-1681
Last Modified 07 Mar 2011 09:33:34
Published 10 Apr 2006 08:02:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2006-1681

Summary

Cross-site scripting (XSS) vulnerability in Cherokee HTTPD 0.5 and earlier allows remote attackers to inject arbitrary web script or HTML via a malformed request that generates an HTTP 400 error, which is not properly handled when the error message is generated.

Vulnerable Systems

Application

  • Cherokee Httpd 0.1

  • Cherokee Httpd 0.1.5

  • Cherokee Httpd 0.1.6

  • Cherokee Httpd 0.2

  • Cherokee Httpd 0.2.5

  • Cherokee Httpd 0.2.6

  • Cherokee Httpd 0.2.7

  • Cherokee Httpd 0.4.17

  • Cherokee Httpd 0.4.6

  • Cherokee Httpd 0.4.7

  • Cherokee Httpd 0.4.8

  • Cherokee Httpd 0.4.9

  • Cherokee Httpd 0.5


References

SECUNIA - 19587

VUPEN - ADV-2006-1292

BID - 17408

BUGTRAQ - 20060406 XSS Bug in Cherokee Webserver

XF - cherokee-handlererror-xss(25698)

OSVDB - 24469


Last Updated: 27 May 2016 10:42:09