Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-1963

Overview

Vulnerability Score 5.5 5.5
CVE Id CVE-2006-1963
Last Modified 07 Mar 2011 09:34:42
Published 21 Apr 2006 06:02:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2006-1963

Summary

Directory traversal vulnerability in main.php in PCPIN Chat 5.0.4 and earlier allows remote authenticated users to include and execute arbitrary PHP code via a ".." (dot dot) in a language cookie, as demonstrated by uploading then accessing a smiliefile image that actually contains PHP code.

Vulnerable Systems

Application

  • Pcpin Chat 3.1.5

  • Pcpin Chat 3.1.6

  • Pcpin Chat 3.1.7r

  • Pcpin Chat 3.2.0

  • Pcpin Chat 3.2.1

  • Pcpin Chat 3.2.3

  • Pcpin Chat 4.0

  • Pcpin Chat 5.0.1

  • Pcpin Chat 5.0.2

  • Pcpin Chat 5.0.3

  • Pcpin Chat 5.0.4


References

VUPEN - ADV-2006-1441

BID - 17632

BUGTRAQ - 20060419 PCPIN Chat <= 5.0.4 "login/language" remote cmmnds xctn

SECUNIA - 19708

MISC - http://retrogod.altervista.org/pcpin_504_xpl.html

XF - pcpin-chat-main-file-include(25962)

BUGTRAQ - 20060604 Re: PCPIN Chat <= 5.0.4 "login/language" remote cmmnds xctn

SECTRACK - 1015968


Last Updated: 27 May 2016 10:42:16