Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-2667

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2006-2667
Last Modified 07 Mar 2011 09:36:44
Published 30 May 2006 05:02:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2006-2667

Summary

Direct static code injection vulnerability in WordPress 2.0.2 and earlier allows remote attackers to execute arbitrary commands by inserting a carriage return and PHP code when updating a profile, which is appended after a special comment sequence into files in (1) wp-content/cache/userlogins/ (2) wp-content/cache/users/ which are later included by cache.php, as demonstrated using the displayname argument.

Vulnerable Systems

Application

  • Wordpress 2.0.2


References

SECUNIA - 20271

XF - wordpress-user-profile-code-injection(26687)

VUPEN - ADV-2006-1992

MISC - http://retrogod.altervista.org/wordpress_202_xpl.html

BID - 18372

OSVDB - 25777

GENTOO - GLSA-200606-08

SECUNIA - 20608


Last Updated: 27 May 2016 10:42:42