Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-2828

Overview

Vulnerability Score 6.4 6.4
CVE Id CVE-2006-2828
Last Modified 05 Sep 2008 05:05:32
Published 05 Jun 2006 04:06:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2006-2828

Summary

Global variable overwrite vulnerability in PHP-Nuke allows remote attackers to conduct remote PHP file inclusion attacks via a modified phpbb_root_path parameter to the admin scripts (1) index.php, (2) admin_ug_auth.php, (3) admin_board.php, (4) admin_disallow.php, (5) admin_forumauth.php, (6) admin_groups.php, (7) admin_ranks.php, (8) admin_styles.php, (9) admin_user_ban.php, (10) admin_words.php, (11) admin_avatar.php, (12) admin_db_utilities.php, (13) admin_forum_prune.php, (14) admin_forums.php, (15) admin_mass_email.php, (16) admin_smilies.php, (17) admin_ug_auth.php, and (18) admin_users.php, which overwrites $phpbb_root_path when the import_request_variables function is executed after $phpbb_root_path has been initialized to a static value.

Vulnerable Systems

Application

  • Php-nuke Ev


References

BUGTRAQ - 20060602 Re: Re: # MHG Security Team --- PHP NUKE All version Remote File Inc.

BUGTRAQ - 20060601 Re: # MHG Security Team --- PHP NUKE All version Remote File Inc.

BUGTRAQ - 20060531 # MHG Security Team --- PHP NUKE All version Remote File Inc.

XF - phpnuke-phpbbrootpath-fileInclude(27368)

SREASON - 1040


Last Updated: 27 May 2016 10:42:46