Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2006-2831

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2006-2831
Last Modified 05 Sep 2008 05:05:33
Published 05 Jun 2006 08:02:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2006-2831

Summary

Drupal 4.6.x before 4.6.8 and 4.7.x before 4.7.2, when running under certain Apache configurations such as when FileInfo overrides are disabled within .htaccess, allows remote attackers to execute arbitrary code by uploading a file with multiple extensions, a variant of CVE-2006-2743.

Vulnerable Systems

Application

  • Drupal 4.6

  • Drupal 4.6.0

  • Drupal 4.6.1

  • Drupal 4.6.2

  • Drupal 4.6.3

  • Drupal 4.6.4

  • Drupal 4.6.5

  • Drupal 4.6.6

  • Drupal 4.6.7

  • Drupal 4.7.0

  • Drupal 4.7.1


References

BUGTRAQ - 20060602 [DRUPAL-SA-2006-007] Drupal 4.6.8 / 4.7.2 fixes arbitrary file execution issue

CONFIRM - http://drupal.org/node/66763

CONFIRM - http://drupal.org/files/sa-2006-007/advisory.txt

BID - 18245

DEBIAN - DSA-1125

SREASON - 1042

SECUNIA - 21244


Last Updated: 27 May 2016 10:42:46