Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4064

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2007-4064
Last Modified 07 Mar 2011 09:57:42
Published 30 Jul 2007 01:30:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-4064

Summary

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 5.x before 5.2, and 4.7.x before 4.7.7, (1) allow remote attackers to inject arbitrary web script or HTML via "some server variables," including PHP_SELF; and (2) allow remote authenticated administrators to inject arbitrary web script or HTML via custom content type names.

Vulnerable Systems

Application

  • Drupal 4.7

  • Drupal 4.7 Rev1.15

  • Drupal 4.7.0

  • Drupal 4.7.1

  • Drupal 4.7.2

  • Drupal 4.7.3

  • Drupal 4.7.4

  • Drupal 4.7.5

  • Drupal 4.7.6

  • Drupal 5.0

  • Drupal 5.1


References

XF - drupal-servervariable-xss(35638)

XF - drupal-contenttype-xss(35637)

VUPEN - ADV-2007-2697

BID - 25097

SECUNIA - 26224

CONFIRM - http://drupal.org/files/sa-2007-018/advisory.txt


Last Updated: 27 May 2016 10:45:46