Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4137

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2007-4137
Last Modified 07 Mar 2011 09:57:52
Published 18 Sep 2007 03:17:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2007-4137

Summary

Off-by-one error in the QUtf8Decoder::toUnicode function in Trolltech Qt 3 allows context-dependent attackers to cause a denial of service (crash) via a crafted Unicode string that triggers a heap-based buffer overflow. NOTE: Qt 4 has the same error in the QUtf8Codec::convertToUnicode function, but it is not exploitable.

Vulnerable Systems

Application

  • Trolltech Qt 3.0

  • Trolltech Qt 3.0.3

  • Trolltech Qt 3.0.5

  • Trolltech Qt 3.1

  • Trolltech Qt 3.1.1

  • Trolltech Qt 3.1.2

  • Trolltech Qt 3.2.1

  • Trolltech Qt 3.2.3

  • Trolltech Qt 3.3.0

  • Trolltech Qt 3.3.1

  • Trolltech Qt 3.3.2

  • Trolltech Qt 3.3.3

  • Trolltech Qt 3.3.4

  • Trolltech Qt 3.3.5

  • Trolltech Qt 3.3.6

  • Trolltech Qt 3.3.7

  • Trolltech Qt 3.3.8

  • Trolltech Qt 4.1

  • Trolltech Qt 4.1.4

  • Trolltech Qt 4.1.5

  • Trolltech Qt 4.2

  • Trolltech Qt 4.2.1

  • Trolltech Qt 4.2.3


References

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=269001

VUPEN - ADV-2007-3144

BID - 25657

REDHAT - RHSA-2007:0883

CONFIRM - http://trolltech.com/company/newsroom/announcements/press.2007-09-03.7564032119

SECUNIA - 26811

SECUNIA - 26782

SECUNIA - 26778

OSVDB - 39384

MISC - http://dist.trolltech.com/developer/download/175791_4.diff

MISC - http://dist.trolltech.com/developer/download/175791_3.diff

CONFIRM - https://issues.rpath.com/browse/RPL-1751

UBUNTU - USN-513-1

BUGTRAQ - 20071004 FLEA-2007-0059-1 qt qt-tools

SUSE - SUSE-SR:2007:019

MANDRIVA - MDKSA-2007:183

DEBIAN - DSA-1426

CONFIRM - http://support.avaya.com/elmodocs2/security/ASA-2007-424.htm

SECTRACK - 1018688

GENTOO - GLSA-200712-08

GENTOO - GLSA-200710-28

SECUNIA - 28021

SECUNIA - 27996

SECUNIA - 27382

SECUNIA - 27275

SECUNIA - 27053

SECUNIA - 26987

SECUNIA - 26882

SECUNIA - 26868

SECUNIA - 26857

SECUNIA - 26804

FEDORA - FEDORA-2007-703

FEDORA - FEDORA-2007-2216

CONFIRM - http://bugs.gentoo.org/show_bug.cgi?id=192472

SGI - 20070901-01-P


Last Updated: 27 May 2016 10:45:46