Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4485

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2007-4485
Last Modified 15 Nov 2008 01:57:12
Published 22 Aug 2007 07:17:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-4485

Summary

PHP remote file inclusion vulnerability in visitor.php in Butterfly online visitors counter 1.08, when used with certain older versions of PHP with improper SERVER superglobal handling, allows remote attackers to execute arbitrary PHP code via a URL in the _SERVER[DOCUMENT_ROOT] parameter. NOTE: it could be argued that this vulnerability is caused by a problem in PHP and the proper fix should be in PHP; if so, then this should not be treated as a vulnerability in Butterfly online visitors counter.

Vulnerable Systems

Application

  • Butterfly 1.08


References

BUGTRAQ - 20070821 Vulnerabilities digest

MISC - http://securityvulns.com/Rdocument845.html

OSVDB - 38327

XF - butterfly-visitor-file-include(36147)

BUGTRAQ - 20071010 Vulnerabilities digest


Last Updated: 27 May 2016 10:45:52