Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4690

Overview

Vulnerability Score 9.0 9.0
CVE Id CVE-2007-4690
Last Modified 07 Mar 2011 09:59:01
Published 14 Nov 2007 08:46:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2007-4690

Summary

Double free vulnerability in the NFS component in Apple Mac OS X 10.4 through 10.4.10 allows remote authenticated users to execute arbitrary code via a crafted AUTH_UNIX RPC packet.

Vulnerable Systems

Operating System

  • Apple Mac Os X 10.4.1

  • Apple Mac Os X 10.4.10

  • Apple Mac Os X 10.4.2

  • Apple Mac Os X 10.4.3

  • Apple Mac Os X 10.4.4

  • Apple Mac Os X 10.4.5

  • Apple Mac Os X 10.4.6

  • Apple Mac Os X 10.4.7

  • Apple Mac Os X 10.4.8

  • Apple Mac Os X 10.4.9

  • Apple Mac Os X Server 10.4.1

  • Apple Mac Os X Server 10.4.10

  • Apple Mac Os X Server 10.4.2

  • Apple Mac Os X Server 10.4.3

  • Apple Mac Os X Server 10.4.4

  • Apple Mac Os X Server 10.4.5

  • Apple Mac Os X Server 10.4.6

  • Apple Mac Os X Server 10.4.7

  • Apple Mac Os X Server 10.4.8

  • Apple Mac Os X Server 10.4.9


References

CERT - TA07-319A

APPLE - APPLE-SA-2007-11-14

XF - macosx-nfs-authunix-code-execution(38477)

VUPEN - ADV-2007-3868

SECTRACK - 1018949

BID - 26444

SECUNIA - 27643

CONFIRM - http://docs.info.apple.com/article.html?artnum=307041

Related Patches

Apple 2007-11-14 Mac OS X 10.4.11 Update (PPC)

Apple 2007-11-14 Mac OS X 10.4.11 Combo Update (PPC)

Apple 2007-11-14 Mac OS X Server 10.4.11 Combo Update (PPC)

Apple 2007-11-14 Mac OS X Server 10.4.11 Update (PPC)


Last Updated: 27 May 2016 10:45:57