Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4784

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2007-4784
Last Modified 05 Feb 2009 01:30:22
Published 10 Sep 2007 05:17:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2007-4784

Summary

The setlocale function in PHP before 5.2.4 allows context-dependent attackers to cause a denial of service (application crash) via a long string in the locale parameter. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless this issue can be demonstrated for code execution.

Vulnerable Systems

Application

  • Php 5.2.3


References

BUGTRAQ - 20070904 PHP < 5.2.4 setlocale() denial of service

OSVDB - 38687

XF - php-setlocale-dos(36458)

GENTOO - GLSA-200710-02

SREASON - 3114

SECUNIA - 28658

SECUNIA - 27102

SUSE - SUSE-SA:2008:004


Last Updated: 27 May 2016 10:45:58