Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4828

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2007-4828
Last Modified 07 Mar 2011 09:59:15
Published 12 Sep 2007 03:17:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-4828

Summary

Cross-site scripting (XSS) vulnerability in the API pretty-printing mode in MediaWiki 1.8.0 through 1.8.4, 1.9.0 through 1.9.3, 1.10.0 through 1.10.1, and the 1.11 development versions before 1.11.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Vulnerable Systems

Application

  • Mediawiki 1.10.0

  • Mediawiki 1.10.1

  • Mediawiki 1.11 Development

  • Mediawiki 1.8.0

  • Mediawiki 1.8.1

  • Mediawiki 1.8.2

  • Mediawiki 1.8.3

  • Mediawiki 1.8.4

  • Mediawiki 1.9.0

  • Mediawiki 1.9.1

  • Mediawiki 1.9.2

  • Mediawiki 1.9.3


References

SECUNIA - 26772

MLIST - [MediaWiki-announce] 20070910 MediaWiki 1.11.0, 1.10.2, 1.9.4, 1.8.5 released

VUPEN - ADV-2007-3130

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=287881

XF - mediawiki-prettyprinting-xss(36558)

BID - 25632

SECUNIA - 26870

FEDORA - FEDORA-2007-2189


Last Updated: 27 May 2016 10:45:58