Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4939

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2007-4939
Last Modified 07 Mar 2011 09:59:41
Published 18 Sep 2007 03:17:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-4939

Summary

Heap-based buffer overflow in mplayerc.exe in Media Player Classic (MPC) 6.4.9.0 and earlier, as used standalone and in mympc (aka CD-Storm) 1.0.0.1, StormPlayer 1.0.4, and possibly other products, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a .avi file with an "indx truck size" of 0xffffffff, and certain wLongsPerEntry and nEntriesInuse values.

Vulnerable Systems

Application

  • Guliverkli Media Player Classic 6.4.9.0

  • Mympc Cd-storm 1.0.0.1

  • Verycd Stormplayer 1.0.4


References

XF - mediaplayerclassic-avi-bo(36583)

VUPEN - ADV-2007-3142

VUPEN - ADV-2007-3141

VUPEN - ADV-2007-3140

MISC - http://www.vulnhunt.com/advisories/CAL-20070912-1_Multiple_vendor_produce_handling_AVI_file_vulnerabilities.txt

BID - 25650

BUGTRAQ - 20070912 CAL-20070912-1 Multiple vendor produce handling AVI file vulnerabilities

SECUNIA - 26808

SECUNIA - 26807

SECUNIA - 26806

SREASON - 3144


Last Updated: 27 May 2016 10:46:01