Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-4992

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2007-4992
Last Modified 05 Sep 2008 05:29:36
Published 10 Oct 2007 08:17:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2007-4992

Summary

Stack-based buffer overflow in the process_packet function in fbserver.exe in Firebird SQL 2.0.2 allows remote attackers to execute arbitrary code via a long request to TCP port 3050.

Vulnerable Systems

Application

  • Firebirdsql Firebird 2.0.2


References

CONFIRM - http://www.firebirdsql.org/rlsnotes/Firebird-2.0.3-ReleaseNotes.pdf

XF - firebirdsql-processpacket-bo(37079)

MISC - http://www.zerodayinitiative.com/advisories/ZDI-07-057.html

BID - 26011

BUGTRAQ - 20071010 ZDI-07-057: Firebird process_packet() Remote Stack Overflow Vulnerability

SECTRACK - 1018802

GENTOO - GLSA-200712-06

SECUNIA - 27982

CONFIRM - http://bugs.gentoo.org/show_bug.cgi?id=195569


Last Updated: 27 May 2016 10:46:02