Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-5247

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2007-5247
Last Modified 15 Nov 2008 02:00:16
Published 06 Oct 2007 01:17:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-5247

Summary

Multiple format string vulnerabilities in the Monolith Lithtech engine, as used by First Encounter Assault Recon (F.E.A.R.) 1.08 and earlier, when Punkbuster (PB) is enabled, allow remote attackers to execute arbitrary code or cause a denial of service (daemon crash) via format string specifiers in (1) a PB_Y packet to the YPG server on UDP port 27888 or (2) a PB_U packet to UCON on UDP port 27888, different vectors than CVE-2004-1500. NOTE: this issue might be in Punkbuster itself, but there are insufficient details to be certain.

Vulnerable Systems

Application

  • Monolith Productions First Encounter Assault Recon 1.08


References

XF - fear-punkbuster-format-string(36900)

BUGTRAQ - 20071001 Format string in F.E.A.R. 1.08 through PB

OSVDB - 45531

OSVDB - 45530

MISC - http://aluigi.org/poc/fearfspb.zip

MISC - http://aluigi.altervista.org/adv/fearfspb-adv.txt

SREASON - 3197


Last Updated: 27 May 2016 10:46:07