Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-5631

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2007-5631
Last Modified 15 Nov 2008 12:00:00
Published 23 Oct 2007 01:46:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-5631

Summary

Multiple PHP remote file inclusion vulnerabilities in PeopleAggregator 1.2pre6, when register_globals is enabled, allow remote attackers to execute arbitrary PHP code via a URL in the current_blockmodule_path parameter to (1) AudiosMediaGalleryModule/AudiosMediaGalleryModule.php, (2) ImagesMediaGalleryModule/ImagesMediaGalleryModule.php, (3) MembersFacewallModule/MembersFacewallModule.php, (4) NewestGroupsModule/NewestGroupsModule.php, (5) UploadMediaModule/UploadMediaModule.php, and (6) VideosMediaGalleryModule/VideosMediaGalleryModule.php in BetaBlockModules/; and (7) the path_prefix parameter to several components.

Vulnerable Systems

Application

  • Peopleaggregator 1.2pre6


References

XF - peopleaggregator-pathprefix-file-include(37349)

BID - 26147

BUGTRAQ - 20071111 PeopleAggregatory security advisory - re CVE-2007-5631

CONFIRM - http://www.myelin.co.nz/post/2007/11/12/#200711121

MILW0RM - 4551

OSVDB - 45501

OSVDB - 45500

OSVDB - 45499

OSVDB - 45498

OSVDB - 45497

OSVDB - 45496

OSVDB - 45495


Last Updated: 27 May 2016 10:46:14