Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-5814

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2007-5814
Last Modified 07 Mar 2011 10:01:21
Published 05 Nov 2007 01:46:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2007-5814

Summary

Multiple buffer overflows in the SonicWall SSL-VPN NetExtender NELaunchCtrl ActiveX control before 2.1.0.51, and 2.5.x before 2.5.0.56, allow remote attackers to execute arbitrary code via a long (1) serverAddress, (2) sessionId, (3) clientIPLower, (4) clientIPHigher, (5) userName, (6) domainName, or (7) dnsSuffix Unicode property value. NOTE: the AddRouteEntry vector is covered by CVE-2007-5603.

Vulnerable Systems

Application

  • Sonicwall Ssl Vpn 2.1

  • Sonicwall Ssl Vpn 2.5


References

XF - sonicwall-nelaunchctrl-bo(38220)

VUPEN - ADV-2007-3696

BID - 26288

BUGTRAQ - 20071101 SEC Consult SA-20071101-0 :: Multiple Vulnerabilities in SonicWALLSSL-VPN Client

MISC - http://www.sec-consult.com/fileadmin/Advisories/20071101-0_sonicwall_multiple.txt

MISC - http://www.sec-consult.com/303.html

SREASON - 3342

SECUNIA - 27469


Last Updated: 27 May 2016 10:46:17