Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-5893

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2007-5893
Last Modified 15 Nov 2008 12:00:00
Published 07 Nov 2007 09:46:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2007-5893

Summary

HTTPSocket.cpp in the C++ Sockets Library before 2.2.5 allows remote attackers to cause a denial of service (crash) via an HTTP request with a missing protocol version number, which triggers an exception. NOTE: some of these details were obtained from third party information.

Vulnerable Systems

Application

  • Alhem C%2b%2b Sockets Library 2.2.4


References

SECUNIA - 27535

XF - csockets-httpsocket-dos(38309)

BID - 26361

CONFIRM - http://www.alhem.net/Sockets/Changelog

OSVDB - 42105


Last Updated: 27 May 2016 10:46:18