Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2007-6249

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2007-6249
Last Modified 15 Nov 2008 02:03:57
Published 14 Dec 2007 08:46:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2007-6249

Summary

etc-update in Portage before 2.1.3.11 on Gentoo Linux relies on the umask to set permissions for the merge file, often resulting in permissions weaker than those of the original files, which might allow local users to obtain sensitive information by reading the merge file.

Vulnerable Systems

Application

  • Gentoo Portage 2.1.3.10


References

CONFIRM - http://sources.gentoo.org/viewcvs.py/portage?rev=7799&view=rev

OSVDB - 42636

CONFIRM - http://bugs.gentoo.org/show_bug.cgi?id=193589

XF - portage-etcupdate-information-disclosure(39035)

SECTRACK - 1019097

BID - 26864

GENTOO - GLSA-200712-11

SECUNIA - 28094


Last Updated: 27 May 2016 10:46:26