Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-0234

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2008-0234
Last Modified 04 Aug 2011 12:00:00
Published 10 Jan 2008 09:46:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-0234

Summary

Buffer overflow in Apple Quicktime Player 7.3.1.70 and other versions before 7.4.1, when RTSP tunneling is enabled, allows remote attackers to execute arbitrary code via a long Reason-Phrase response to an rtsp:// request, as demonstrated using a 404 error message.

Vulnerable Systems

Application

  • Apple Quicktime 7.3.1.70

  • Apple Quicktime 7.4


References

CERT-VN - VU#112179

APPLE - APPLE-SA-2008-07-10

XF - quicktime-rtsp-responses-bo(39601)

VUPEN - ADV-2008-2064

VUPEN - ADV-2008-0107

SECTRACK - 1019178

BID - 27225

BUGTRAQ - 20080112 Re: Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080112 Re: Re: Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080114 Re: [Full-disclosure] Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080111 Re: Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080111 Re: Re: Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080110 Re: Buffer-overflow in Quicktime Player 7.3.1.70

BUGTRAQ - 20080110 Buffer-overflow in Quicktime Player 7.3.1.70

MILW0RM - 4906

MILW0RM - 4885

SREASON - 3537

SECUNIA - 31034

SECUNIA - 28423

APPLE - APPLE-SA-2008-02-06

Related Patches

Apple 2008-02-06 QuickTime 7.4.1 for Panther

Apple 2008-02-06 QuickTime 7.4.1 for Leopard

Apple 2008-02-06 QuickTime 7.4.1 for Tiger


Last Updated: 27 May 2016 10:46:43