Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-0727

Overview

Vulnerability Score 8.5 8.5
CVE Id CVE-2008-0727
Last Modified 07 Mar 2011 10:05:21
Published 17 Mar 2008 08:44:00
Confidentiality Impact NONE NONE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2008-0727

Summary

Multiple buffer overflows in oninit.exe in IBM Informix Dynamic Server (IDS) 7.x through 11.x allow (1) remote attackers to execute arbitrary code via a long password and (2) remote authenticated users to execute arbitrary code via a long DBPATH value.

Vulnerable Systems

Application

  • Ibm Informix Dynamic Server 10.0

  • Ibm Informix Dynamic Server 10.0.xc3

  • Ibm Informix Dynamic Server 10.0.xc4

  • Ibm Informix Dynamic Server 10.00.xc7w1

  • Ibm Informix Dynamic Server 11.10.xc2

  • Ibm Informix Dynamic Server 7.3

  • Ibm Informix Dynamic Server 7.31.xd8

  • Ibm Informix Dynamic Server 7.31.xd9

  • Ibm Informix Dynamic Server 9.3

  • Ibm Informix Dynamic Server 9.4

  • Ibm Informix Dynamic Server 9.40 Xc7

  • Ibm Informix Dynamic Server 9.40.tc5

  • Ibm Informix Dynamic Server 9.40.uc1

  • Ibm Informix Dynamic Server 9.40.uc2

  • Ibm Informix Dynamic Server 9.40.uc3

  • Ibm Informix Dynamic Server 9.40.uc5

  • Ibm Informix Dynamic Server 9.40.xd8


References

XF - ibm-informix-oninit-bo(41203)

XF - ibm-informix-oninit-dbpath-bo(41202)

MISC - http://www.zerodayinitiative.com/advisories/ZDI-08-012/

MISC - http://www.zerodayinitiative.com/advisories/ZDI-08-011/

VUPEN - ADV-2008-0860

BID - 28198

BUGTRAQ - 20080313 ZDI-08-012: IBM Informix Dynamic Server Authentication Password Stack Overflow Vulnerability

BUGTRAQ - 20080313 ZDI-08-011: IBM Informix Dynamic Server DBPATH Buffer Overflow Vulnerability

AIXAPAR - IC55210

AIXAPAR - IC55209

AIXAPAR - IC55208

AIXAPAR - IC55207

SECUNIA - 29272

SREASON - 3749


Last Updated: 27 May 2016 10:46:54