Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-1110

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2008-1110
Last Modified 10 Sep 2008 09:06:50
Published 29 Feb 2008 02:44:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-1110

Summary

Buffer overflow in demuxers/demux_asf.c (aka the ASF demuxer) in the xineplug_dmx_asf.so plugin in xine-lib before 1.1.10 allows remote attackers to execute arbitrary code or cause a denial of service (crash) via a crafted ASF header. NOTE: this issue leads to a crash when an attack uses the CVE-2006-1664 exploit code, but it is different from CVE-2006-1664.

Vulnerable Systems

Application

  • Xine-lib 1.1.9

  • Xine-plugin 1.1.9


References

CONFIRM - http://xinehq.de/index.php/news

CONFIRM - http://sourceforge.net/project/shownotes.php?group_id=9655&release_id=571608

CONFIRM - http://xinehq.de/index.php/security

UBUNTU - USN-635-1

MILW0RM - 1641

MANDRIVA - MDVSA-2008:178

GENTOO - GLSA-200802-12

SECUNIA - 31393

SECUNIA - 29141

CONFIRM - http://hg.debian.org/hg/xine-lib/xine-lib?cmd=changeset;node=fb6d089b520dca199ef16a046da28c50c984c2d2;style=gitweb

CONFIRM - http://bugs.gentoo.org/show_bug.cgi?id=208100

XF - xinelib-demuxasf-bo(41019)


Last Updated: 27 May 2016 10:47:02