Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-1215

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2008-1215
Last Modified 05 Sep 2008 05:37:09
Published 08 Mar 2008 09:44:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2008-1215

Summary

Stack-based buffer overflow in the command_Expand_Interpret function in command.c in ppp (aka user-ppp), as distributed in FreeBSD 6.3 and 7.0, OpenBSD 4.1 and 4.2, and the net/userppp package for NetBSD, allows local users to gain privileges via long commands containing "~" characters.

Vulnerable Systems

Operating System

  • Freebsd 6.3

  • Freebsd 7.0

  • Netbsd

  • Openbsd 4.1

  • Openbsd 4.2


References

BID - 28090

VULN-DEV - 20080301 Re: *BSD user-ppp local root (when conditions permit)

VULN-DEV - 20080229 *BSD user-ppp local root (when conditions permit)

OPENBSD - [4.2] 20080307 009: SECURITY FIX: March 7, 2008

OPENBSD - [4.1] 20080307 014: SECURITY FIX: March 7, 2008

SECUNIA - 29240

SECUNIA - 29238

SECUNIA - 29234

XF - userppp-commandexpandinterpret-bo(41034)


Last Updated: 27 May 2016 10:47:04