Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-1856

Overview

Vulnerability Score 5.1 5.1
CVE Id CVE-2008-1856
Last Modified 07 Mar 2011 10:07:58
Published 16 Apr 2008 03:05:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity HIGH
Authentication NONE

CVE-2008-1856

Summary

plugins/maps/db_handler.php in LinPHA 1.3.3 and earlier does not require authentication for a settings action that modifies the configuration file, which allows remote attackers to conduct directory traversal attacks and execute arbitrary local files by placing directory traversal sequences into the maps_type configuration setting, and then sending a request to maps_view.php, which causes plugins/maps/map.main.class.php to use the modified configuration.

Vulnerable Systems

Application

  • Linpha

  • Linpha 0.9.0

  • Linpha 0.9.1

  • Linpha 0.9.2

  • Linpha 0.9.3

  • Linpha 0.9.4

  • Linpha 1.0

  • Linpha 1.1.0

  • Linpha 1.1.1

  • Linpha 1.2.0

  • Linpha 1.3.0

  • Linpha 1.3.1

  • Linpha 1.3.2


References

XF - linpha-mapmainclass-file-include(41676)

VUPEN - ADV-2008-1136

BID - 28654

OSVDB - 50229

MILW0RM - 5392

CONFIRM - http://sourceforge.net/project/shownotes.php?release_id=595725

SECUNIA - 29724


Last Updated: 27 May 2016 10:47:40