Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-3443

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2008-3443
Last Modified 21 Aug 2010 01:22:41
Published 14 Aug 2008 07:41:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2008-3443

Summary

The regular expression engine (regex.c) in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 allows remote attackers to cause a denial of service (infinite loop and crash) via multiple long requests to a Ruby socket, related to memory allocation failure, and as demonstrated against Webrick.

Vulnerable Systems

Application

  • Ruby-lang Ruby 1.6.8

  • Ruby-lang Ruby 1.8.0

  • Ruby-lang Ruby 1.8.1

  • Ruby-lang Ruby 1.8.2

  • Ruby-lang Ruby 1.8.3

  • Ruby-lang Ruby 1.8.4

  • Ruby-lang Ruby 1.8.5

  • Ruby-lang Ruby 1.8.6

  • Ruby-lang Ruby 1.8.7

  • Ruby-lang Ruby 1.9.0


References

CERT - TA09-133A

FEDORA - FEDORA-2008-8736

FEDORA - FEDORA-2008-8738

XF - ruby-regex-dos(44688)

VUPEN - ADV-2009-1297

UBUNTU - USN-691-1

UBUNTU - USN-651-1

SECTRACK - 1021075

BID - 30682

REDHAT - RHSA-2008:0897

REDHAT - RHSA-2008:0895

MILW0RM - 6239

DEBIAN - DSA-1695

CONFIRM - http://support.avaya.com/elmodocs2/security/ASA-2008-424.htm

CONFIRM - http://support.apple.com/kb/HT3549

SREASON - 4158

SECUNIA - 35074

SECUNIA - 33398

SECUNIA - 33185

SECUNIA - 32372

SECUNIA - 32371

SECUNIA - 32219

SECUNIA - 32165

SECUNIA - 31430

APPLE - APPLE-SA-2009-05-12

Related Patches

Apple 2009-05-12 Mac OS X 10.5.7 Combo Update

Apple 2009-05-12 Mac OS X Server 10.5.7 Update

Apple 2009-05-12 Mac OS X 10.5.7 Update

Apple 2009-05-12 Mac OS X Server 10.5.7 Combo Update


Last Updated: 27 May 2016 10:48:12