Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-3889

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2008-3889
Last Modified 19 Mar 2012 12:00:00
Published 12 Sep 2008 12:56:20
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2008-3889

Summary

Postfix 2.4 before 2.4.9, 2.5 before 2.5.5, and 2.6 before 2.6-20080902, when used with the Linux 2.6 kernel, leaks epoll file descriptors during execution of "non-Postfix" commands, which allows local users to cause a denial of service (application slowdown or exit) via a crafted command, as demonstrated by a command in a .forward file.

Vulnerable Systems

Application

  • Postfix 2.4

  • Postfix 2.4.0

  • Postfix 2.4.1

  • Postfix 2.4.2

  • Postfix 2.4.3

  • Postfix 2.4.4

  • Postfix 2.4.5

  • Postfix 2.4.6

  • Postfix 2.4.7

  • Postfix 2.4.8

  • Postfix 2.5.1

  • Postfix 2.5.2

  • Postfix 2.5.3

  • Postfix 2.6


References

CONFIRM - http://www.postfix.org/announcements/20080902.html

FEDORA - FEDORA-2008-8593

FEDORA - FEDORA-2008-8595

XF - postfix-filedescriptor-dos(44865)

MISC - http://www.wekk.net/research/CVE-2008-3889/

UBUNTU - USN-642-1

BID - 30977

BUGTRAQ - 20081104 rPSA-2008-0311-1 postfix

BUGTRAQ - 20080916 [Suspected Spam][CVE-2008-4042] Postfix Linux-only local denial of service - PoC

BUGTRAQ - 20080902 Postfix Linux-only local denial of service

MILW0RM - 6472

MANDRIVA - MDVSA-2008:190

CONFIRM - http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0311

SECTRACK - 1020800

SREASON - 4239

GENTOO - GLSA-200809-09

SECUNIA - 32231

SECUNIA - 31986

SECUNIA - 31982

SECUNIA - 31800

SECUNIA - 31716

SUSE - SUSE-SR:2008:018


Last Updated: 27 May 2016 10:48:20