Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-3971

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2008-3971
Last Modified 19 Aug 2009 01:19:05
Published 10 Sep 2008 09:13:47
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-3971

Summary

Heap-based buffer overflow in the open_man_file function in callbacks.c in gmanedit 0.4.1 allows remote attackers to execute arbitrary code via a crafted man page, which is not properly handled during utf8 conversion. NOTE: another overflow was reported using a configuration file, but that vector does not have a scenario that crosses privilege boundaries.

Vulnerable Systems

Application

  • Gmanedit2 Gmanedit 0.4.1


References

XF - gmanedit-glocaletoutf8-bo(44963)

XF - gmanedit-readconffromfile-bo(44962)

BID - 31040

MLIST - [oss-security] 20080909 Re: CVE id requests: gmanedit

MLIST - [oss-security] 20080906 CVE id requests: gmanedit

CONFIRM - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497835


Last Updated: 27 May 2016 10:48:22