Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-5185

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2008-5185
Last Modified 17 Feb 2009 01:54:06
Published 20 Nov 2008 09:30:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2008-5185

Summary

The highlighting functionality in geshi.php in GeSHi before 1.0.8 allows remote attackers to cause a denial of service (infinite loop) via an XML sequence containing an opening delimiter without a closing delimiter, as demonstrated using "<".

Vulnerable Systems

Application

  • Geshi 1.0.0

  • Geshi 1.0.1

  • Geshi 1.0.2

  • Geshi 1.0.2 Beta 1

  • Geshi 1.0.3

  • Geshi 1.0.4

  • Geshi 1.0.5

  • Geshi 1.0.6

  • Geshi 1.0.7

  • Geshi 1.0.7.1

  • Geshi 1.0.7.10

  • Geshi 1.0.7.11

  • Geshi 1.0.7.12

  • Geshi 1.0.7.13

  • Geshi 1.0.7.14

  • Geshi 1.0.7.15

  • Geshi 1.0.7.16

  • Geshi 1.0.7.17

  • Geshi 1.0.7.18

  • Geshi 1.0.7.19

  • Geshi 1.0.7.2

  • Geshi 1.0.7.20

  • Geshi 1.0.7.21

  • Geshi 1.0.7.22

  • Geshi 1.0.7.3

  • Geshi 1.0.7.4

  • Geshi 1.0.7.5

  • Geshi 1.0.7.6

  • Geshi 1.0.7.7

  • Geshi 1.0.7.8

  • Geshi 1.0.7.9


References

XF - geshi-xml-dos(46769)

BID - 32377

MLIST - [oss-security] 20081120 CVE id request: another geshi issue (was: [oss-security] GeSHi: Clarification about the recent security (non-)issues (SA32559))

CONFIRM - http://geshi.svn.sourceforge.net/viewvc/geshi/trunk/geshi-1.0.X/src/geshi.php?r1=1321&r2=1322&view=patch


Last Updated: 27 May 2016 10:48:44