Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-5278

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2008-5278
Last Modified 20 Aug 2009 01:23:05
Published 28 Nov 2008 02:30:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-5278

Summary

Cross-site scripting (XSS) vulnerability in the self_link function in in the RSS Feed Generator (wp-includes/feed.php) for WordPress before 2.6.5 allows remote attackers to inject arbitrary web script or HTML via the Host header (HTTP_HOST variable).

Vulnerable Systems

Application

  • Wordpress 0.6.2

  • Wordpress 0.6.2.1

  • Wordpress 0.7

  • Wordpress 0.71

  • Wordpress 0.71-gold

  • Wordpress 0.711

  • Wordpress 0.72

  • Wordpress 1.0

  • Wordpress 1.0-platinum

  • Wordpress 1.0.1

  • Wordpress 1.0.1-miles

  • Wordpress 1.0.2

  • Wordpress 1.0.2-blakey

  • Wordpress 1.2

  • Wordpress 1.2-delta

  • Wordpress 1.2-mingus

  • Wordpress 1.2.1

  • Wordpress 1.2.2

  • Wordpress 1.3.1

  • Wordpress 1.4

  • Wordpress 1.5

  • Wordpress 1.5-strayhorn

  • Wordpress 1.5.1

  • Wordpress 1.5.1.1

  • Wordpress 1.5.1.2

  • Wordpress 1.5.1.3

  • Wordpress 1.5.2

  • Wordpress 1.6

  • Wordpress 2.0

  • Wordpress 2.0.1

  • Wordpress 2.0.10

  • Wordpress 2.0.10 Rc1

  • Wordpress 2.0.10 Rc2

  • Wordpress 2.0.11

  • Wordpress 2.0.2

  • Wordpress 2.0.3

  • Wordpress 2.0.4

  • Wordpress 2.0.5

  • Wordpress 2.0.6

  • Wordpress 2.0.7

  • Wordpress 2.0.8

  • Wordpress 2.0.9

  • Wordpress 2.1

  • Wordpress 2.1.1

  • Wordpress 2.1.2

  • Wordpress 2.1.3

  • Wordpress 2.1.3 Rc1

  • Wordpress 2.1.3 Rc2

  • Wordpress 2.2

  • Wordpress 2.2 Revision5002

  • Wordpress 2.2 Revision5003

  • Wordpress 2.2.0

  • Wordpress 2.2.1

  • Wordpress 2.2.2

  • Wordpress 2.2.3

  • Wordpress 2.3

  • Wordpress 2.3.1

  • Wordpress 2.3.2

  • Wordpress 2.3.3

  • Wordpress 2.5

  • Wordpress 2.5.1

  • Wordpress 2.6

  • Wordpress 2.6.1

  • Wordpress 2.6.3


References

CONFIRM - http://wordpress.org/development/2008/11/wordpress-265/

FEDORA - FEDORA-2008-10468

FEDORA - FEDORA-2008-10483

XF - wordpress-feed-xss(46882)

BID - 32476

BUGTRAQ - 20081125 WordPress XSS vulnerability in RSS Feed Generator

SREASON - 4662

SECUNIA - 32966

SECUNIA - 32882

OSVDB - 50214


Last Updated: 27 May 2016 10:48:46