Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-2154

Overview

Vulnerability Score 6.0 6.0
CVE Id CVE-2008-2154
Last Modified 15 Jul 2009 01:29:05
Published 03 Jun 2009 05:00:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication SINGLE_INSTANCE

CVE-2008-2154

Summary

IBM DB2 8 before FP17, 9.1 before FP5, and 9.5 before FP2 provides an INSTALL_JAR (aka sqlj.install_jar) procedure, which allows remote authenticated users to create or overwrite arbitrary files via unspecified calls.

Vulnerable Systems

Application

  • Ibm Db2 8.0

  • Ibm Db2 9.1

  • Ibm Db2 9.5


References

CONFIRM - http://www-01.ibm.com/support/docview.wss?uid=swg21318189

AIXAPAR - IZ22143

AIXAPAR - IZ22142

CONFIRM - ftp://ftp.software.ibm.com/ps/products/db2/fixes/english-us/aparlist/db2_v82/APARLIST.TXT

XF - db2-installjar-priv-escalation(51105)

BID - 35409

AIXAPAR - IZ21983

SECUNIA - 31787

OSVDB - 48147


Last Updated: 27 May 2016 10:47:46