Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-5904

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2008-5904
Last Modified 10 Feb 2009 01:59:07
Published 15 Jan 2009 12:30:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2008-5904

Summary

The rdp_rdp_process_color_pointer_pdu function in rdp/rdp_rdp.c in xrdp 0.4.1 and earlier allows remote RDP servers to have an unknown impact via input data that sets crafted values for certain length variables, leading to a buffer overflow.

Vulnerable Systems

Application

  • Xrdp 0.3

  • Xrdp 0.3.1

  • Xrdp 0.3.2

  • Xrdp 0.4

  • Xrdp 0.4.1


References

XF - xrdp-rdprdpprocesscolorpointerpdu-bo(48094)

MISC - http://packetstormsecurity.org/0812-advisories/VA_VD_87_08_XRDP.pdf

MLIST - [oss-security] 20090112 CVE request: xrdp

SUSE - SUSE-SR:2009:003


Last Updated: 27 May 2016 10:48:58