Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-5942

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2008-5942
Last Modified 05 Feb 2009 01:52:45
Published 22 Jan 2009 06:30:05
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-5942

Summary

Multiple cross-site scripting (XSS) vulnerabilities in MODx before 0.9.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the preserveUrls function and (2) "username input." NOTE: vector 2 may be related to CVE-2008-5939.

Vulnerable Systems

Application

  • Modxcms 0.9.0

  • Modxcms 0.9.1

  • Modxcms 0.9.2.1

  • Modxcms 0.9.5

  • Modxcms 0.9.6

  • Modxcms 0.9.6.1

  • Modxcms 0.9.6.2


References

XF - modx-preserveurls-xss(48184)

BID - 33184

CONFIRM - http://svn.modxcms.com/svn/tattoo/tattoo/releases/0.9.6.3/install/changelog.txt

JVNDB - JVNDB-2009-000003

JVN - JVN#10170564


Last Updated: 27 May 2016 10:49:00