Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-6229

Overview

Vulnerability Score 3.5 3.5
CVE Id CVE-2008-6229
Last Modified 07 Mar 2011 10:15:56
Published 20 Feb 2009 06:30:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication SINGLE_INSTANCE

CVE-2008-6229

Summary

Cross-site scripting (XSS) vulnerability in the administrative interface in Drupal Content Construction Kit (CCK) 5.x before 5.x-1.10 and 6.x before 6.x-2.0, a module for Drupal, allows remote authenticated users with "administer content" permissions to inject arbitrary web script or HTML via (1) field labels and (2) content-type names.

Vulnerable Systems

Application

  • Drupal Content Construction Kit 5.x-1.0

  • Drupal Content Construction Kit 5.x-1.1

  • Drupal Content Construction Kit 5.x-1.2

  • Drupal Content Construction Kit 5.x-1.3

  • Drupal Content Construction Kit 5.x-1.4

  • Drupal Content Construction Kit 5.x-1.5

  • Drupal Content Construction Kit 5.x-1.6

  • Drupal Content Construction Kit 5.x-1.7

  • Drupal Content Construction Kit 5.x-1.8

  • Drupal Content Construction Kit 5.x-1.9

  • Drupal Content Construction Kit 5.x-1.x-dev

  • Drupal Content Construction Kit 6.x-1.0

  • Drupal Content Construction Kit 6.x-1.x-dev


References

BID - 32136

CONFIRM - http://drupal.org/node/330546

FEDORA - FEDORA-2008-9479

XF - cck-fieldlabels-contenttype-xss(46377)

VUPEN - ADV-2008-3030

SECUNIA - 32615

SECUNIA - 32572


Last Updated: 27 May 2016 10:49:06