Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-6681

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2008-6681
Last Modified 28 Apr 2009 01:37:04
Published 09 Apr 2009 11:08:35
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2008-6681

Summary

Cross-site scripting (XSS) vulnerability in dijit.Editor in Dojo before 1.1 allows remote attackers to inject arbitrary web script or HTML via XML entities in a TEXTAREA element.

Vulnerable Systems

Application

  • Dojotoolkit Dojo 0.1.0

  • Dojotoolkit Dojo 0.2.0

  • Dojotoolkit Dojo 0.2.1

  • Dojotoolkit Dojo 0.2.2

  • Dojotoolkit Dojo 0.3.0

  • Dojotoolkit Dojo 0.3.1

  • Dojotoolkit Dojo 0.4.0

  • Dojotoolkit Dojo 0.4.1

  • Dojotoolkit Dojo 0.4.2

  • Dojotoolkit Dojo 0.4.3

  • Dojotoolkit Dojo 0.9.0

  • Dojotoolkit Dojo 1.0


References

XF - dojo-dijiteditor-xss(49883)

BID - 34661

CONFIRM - http://www.dojotoolkit.org/book/dojo-1-1-release-notes

MISC - http://trac.dojotoolkit.org/ticket/2140


Last Updated: 27 May 2016 10:49:17