Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0129

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2009-0129
Last Modified 16 Jan 2009 12:00:00
Published 15 Jan 2009 12:30:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2009-0129

Summary

libcrypt-openssl-dsa-perl does not properly check the return value from the OpenSSL DSA_verify and DSA_do_verify functions, which might allow remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.

Vulnerable Systems

Application

  • Perl-openssl Libcrypt-openssl-dsa-perl Nil


References

MLIST - [oss-security] 20090112 CVE Request -- tsqllib, slurm-llnl, libnasl, libcrypt-openssl-dsa-perl, erlang, boinc-client, m2crypto

CONFIRM - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511519


Last Updated: 27 May 2016 10:50:07