Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0136

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2009-0136
Last Modified 07 Mar 2011 10:17:56
Published 16 Jan 2009 01:30:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-0136

Summary

Multiple array index errors in the Audible::Tag::readTag function in metadata/audible/audibletag.cpp in Amarok 1.4.10 through 2.0.1 allow remote attackers to cause a denial of service (application crash) or execute arbitrary code via an Audible Audio (.aa) file with a crafted (1) nlen or (2) vlen Tag value, each of which can lead to an invalid pointer dereference, or the writing of a 0x00 byte to an arbitrary memory location, after an allocation failure.

Vulnerable Systems

Application

  • Amarok 1.4.10

  • Amarok 2.0

  • Amarok 2.0.1


References

FEDORA - FEDORA-2009-0715

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=479946

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=479560

VUPEN - ADV-2009-0100

UBUNTU - USN-739-1

SECTRACK - 1021558

BID - 33210

BUGTRAQ - 20090111 [TKADV2009-002] Amarok Integer Overflow and Unchecked Allocation Vulnerabilities

MANDRIVA - MDVSA-2009:030

DEBIAN - DSA-1706

CONFIRM - http://websvn.kde.org/?view=rev&revision=908415

CONFIRM - http://websvn.kde.org/?view=rev&revision=908401

CONFIRM - http://websvn.kde.org/?view=rev&revision=908391

MISC - http://trapkit.de/advisories/TKADV2009-002.txt

SREASON - 4915

GENTOO - GLSA-200903-34

SECUNIA - 34407

SECUNIA - 34315

SECUNIA - 33819

SECUNIA - 33640

SECUNIA - 33522

SECUNIA - 33505

MLIST - [oss-security] 20090114 CVE Request -- amarok

SUSE - SUSE-SR:2009:003

CONFIRM - http://bugs.gentoo.org/show_bug.cgi?id=254896

CONFIRM - http://amarok.kde.org/en/releases/2.0.1.1


Last Updated: 27 May 2016 10:50:07