Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0224

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2009-0224
Last Modified 21 Aug 2010 01:29:57
Published 12 May 2009 06:30:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-0224

Summary

Microsoft Office PowerPoint 2000 SP3, 2002 SP3, 2003 SP3, and 2007 SP1 and SP2; PowerPoint Viewer 2003 and 2007 SP1 and SP2; PowerPoint in Microsoft Office 2004 for Mac and 2008 for Mac; Open XML File Format Converter for Mac; Microsoft Works 8.5 and 9.0; and Microsoft Office Compatibility Pack for Word, Excel, and PowerPoint 2007 File Formats SP1 and SP2 do not properly validate PowerPoint files, which allows remote attackers to execute arbitrary code via multiple crafted BuildList records that include ChartBuild containers, which triggers memory corruption, aka "Memory Corruption Vulnerability."

Vulnerable Systems

Application

  • Microsoft Compatibility Pack Word Excel Powerpoint 2007

  • Microsoft Office Compatibility Pack For Word Excel Ppt 2007

  • Microsoft Office Powerpoint 2000

  • Microsoft Office Powerpoint 2002

  • Microsoft Office Powerpoint 2003

  • Microsoft Office Powerpoint 2007

  • Microsoft Office Powerpoint Viewer 2003

  • Microsoft Office Powerpoint Viewer 2007

  • Microsoft Open Xml File Format Converter

  • Microsoft Powerpoint 2004

  • Microsoft Powerpoint 2008

  • Microsoft Works 8.5

  • Microsoft Works 9.0


References

CERT - TA09-132A

MS - MS09-017

VUPEN - ADV-2009-1290

SECTRACK - 1022205

BID - 34879

SECUNIA - 32428

IDEFENSE - 20090512 Microsoft PowerPoint Build List Memory Corruption Vulnerability

Related Patches

MS 953331 (English/MUI) Office Compatibility Pack Service Pack 2 (Rev 2)

MS09-017 967340 957790 (English/MUI) Security Update for Microsoft PowerPoint 2000


Last Updated: 27 May 2016 10:50:10