Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0367

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2009-0367
Last Modified 27 Apr 2010 01:48:55
Published 04 Mar 2009 09:30:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-0367

Summary

The Python AI module in Wesnoth 1.4.x and 1.5 before 1.5.11 allows remote attackers to escape the sandbox and execute arbitrary code by using a whitelisted module that imports an unsafe module, then using a hierarchical module name to access the unsafe module through the whitelisted module.

Vulnerable Systems

Application

  • Wesnoth 1.4

  • Wesnoth 1.4.1

  • Wesnoth 1.4.2

  • Wesnoth 1.4.3

  • Wesnoth 1.4.4

  • Wesnoth 1.4.5

  • Wesnoth 1.4.6

  • Wesnoth 1.4.7

  • Wesnoth 1.5.0

  • Wesnoth 1.5.1

  • Wesnoth 1.5.10

  • Wesnoth 1.5.2

  • Wesnoth 1.5.3

  • Wesnoth 1.5.4

  • Wesnoth 1.5.5

  • Wesnoth 1.5.6

  • Wesnoth 1.5.7

  • Wesnoth 1.5.8

  • Wesnoth 1.5.9


References

CONFIRM - http://www.wesnoth.org/forum/viewtopic.php?t=24340

CONFIRM - http://www.wesnoth.org/forum/viewtopic.php?t=24247

VUPEN - ADV-2009-0595

CONFIRM - https://gna.org/bugs/index.php?13048

XF - wesnoth-pythonai-code-execution(49058)

DEBIAN - DSA-1737

SECUNIA - 34236

SECUNIA - 34058

CONFIRM - http://packages.debian.org/changelogs/pool/main/w/wesnoth/wesnoth_1.5.12-1/changelog

CONFIRM - http://packages.debian.org/changelogs/pool/main/w/wesnoth/wesnoth_1.4.7-4/changelog

CONFIRM - http://launchpad.net/bugs/cve/2009-0367

CONFIRM - http://launchpad.net/bugs/336396

CONFIRM - http://launchpad.net/bugs/335089


Last Updated: 27 May 2016 10:50:14