Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0478

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2009-0478
Last Modified 18 Aug 2009 12:00:00
Published 08 Feb 2009 05:30:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2009-0478

Summary

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Vulnerable Systems

Application

  • Squid 2.7.stable1

  • Squid 2.7.stable2

  • Squid 2.7.stable3

  • Squid 2.7.stable4

  • Squid 2.7.stable5

  • Squid 3.0.stable1

  • Squid 3.0.stable10

  • Squid 3.0.stable11

  • Squid 3.0.stable12

  • Squid 3.0.stable2

  • Squid 3.0.stable3

  • Squid 3.0.stable4

  • Squid 3.0.stable5

  • Squid 3.0.stable6

  • Squid 3.0.stable7

  • Squid 3.0.stable8

  • Squid 3.0.stable9

  • Squid 3.1

  • Squid 3.1.0.1

  • Squid 3.1.0.2

  • Squid 3.1.0.3

  • Squid 3.1.0.4


References

BID - 33604

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=484246

CONFIRM - http://www.squid-cache.org/Versions/v2/2.7/changesets/12432.patch

CONFIRM - http://www.squid-cache.org/Advisories/SQUID-2009_1.txt

SECTRACK - 1021684

BUGTRAQ - 20090204 Squid Proxy Cache Denial of Service in request handling

MILW0RM - 8021

MANDRIVA - MDVSA-2009:034

GENTOO - GLSA-200903-38

SECUNIA - 34467

SECUNIA - 33731

SUSE - SUSE-SR:2009:005


Last Updated: 27 May 2016 10:50:16