Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-0796

Overview

Vulnerability Score 2.6 2.6
CVE Id CVE-2009-0796
Last Modified 18 Nov 2010 01:26:34
Published 07 Apr 2009 07:30:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication NONE

CVE-2009-0796

Summary

Cross-site scripting (XSS) vulnerability in Status.pm in Apache::Status and Apache2::Status in mod_perl1 and mod_perl2 for the Apache HTTP Server, when /perl-status is accessible, allows remote attackers to inject arbitrary web script or HTML via the URI.

Vulnerable Systems

Application

  • Apache Mod Perl 1

  • Apache Mod Perl 2


References

CONFIRM - http://svn.apache.org/viewvc?view=rev&revision=761081

MISC - https://launchpad.net/bugs/cve/2009-0796

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=494402

VUPEN - ADV-2009-0943

SECTRACK - 1021988

BID - 34383

BUGTRAQ - 20090415 XSS with mod_perl perl_status utility

MANDRIVA - MDVSA-2009:091

MLIST - [modperl] 20090401 [SECURITY] [CVE-2009-0796] Vulnerability found in Apache::Status and Apache2::Status

MLIST - [modperl-cvs] 20090401 svn commit: r761081 - in /perl/modperl/branches/1.x: Changes lib/Apache/Status.pm

CONFIRM - http://svn.apache.org/viewvc/perl/modperl/branches/1.x/lib/Apache/Status.pm?r1=177851&r2=761081&pathrev=761081&diff_format=h

CONFIRM - http://support.apple.com/kb/HT4435

SUNALERT - 1021709

SUNALERT - 1021508

SECUNIA - 34597

APPLE - APPLE-SA-2010-11-10-1

Related Patches

Apple 2010-11-10 Mac OS X 10.6.5 Combo Update (See Notes)

Apple 2010-11-10 Security Update 2010-007 (Leopard) (See Notes)

Apple 2010-11-10 Security Update 2010-007 Server (Leopard) (See Notes)

Apple 2010-11-10 Mac OS X 10.6.5 Update (See Notes)


Last Updated: 27 May 2016 10:50:22