Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-1088

Overview

Vulnerability Score 9.0 9.0
CVE Id CVE-2009-1088
Last Modified 05 Oct 2009 12:00:00
Published 25 Mar 2009 02:30:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2009-1088

Summary

Hannon Hill Cascade Server 5.7 and other versions allows remote authenticated users to execute arbitrary programs or Java code via a crafted XSLT stylesheet with "extension elements and extension functions" that trigger code execution by Xalan-Java, as demonstrated using xalan://java.lang.Runtime.

Vulnerable Systems

Application

  • Hannonhill Cascade 5.7


References

XF - cascadeserver-xlst-command-execution(49332)

BID - 34186

BUGTRAQ - 20090319 Command Execution in Hannon Hill Cascade Server

MILW0RM - 8247


Last Updated: 27 May 2016 10:50:28