Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-1721

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2009-1721
Last Modified 22 Oct 2012 11:06:36
Published 31 Jul 2009 03:00:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-1721

Summary

The decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger a free of an uninitialized pointer.

Vulnerable Systems

Application

  • Openexr 1.2.2

  • Openexr 1.6.1


References

CERT - TA09-218A

BID - 35838

CONFIRM - http://security.debian.org/pool/updates/main/o/openexr/openexr_1.6.1-3+lenny3.diff.gz

CONFIRM - http://security.debian.org/pool/updates/main/o/openexr/openexr_1.2.2-4.3+etch2.diff.gz

CONFIRM - http://release.debian.org/proposed-updates/stable_diffs/openexr_1.6.1-3%2Blenny3.debdiff

FEDORA - FEDORA-2009-8136

FEDORA - FEDORA-2009-8132

VUPEN - ADV-2009-2172

VUPEN - ADV-2009-2035

SECTRACK - 1022674

MANDRIVA - MDVSA-2009:191

MANDRIVA - MDVSA-2009:190

DEBIAN - DSA-1842

CONFIRM - http://support.apple.com/kb/HT3757

SECUNIA - 36123

SECUNIA - 36096

SECUNIA - 36032

SECUNIA - 36030

APPLE - APPLE-SA-2009-08-05-1

UBUNTU - USN-831-1

SECUNIA - 36753

Related Patches

Apple 2009-08-12 Security Update 2009-003 2009-004 Server (Tiger PPC)

Apple 2009-08-12 Security Update 2009-003 2009-004 (Tiger PPC)

Apple 2009-08-31 Mac OS X Server 10.5.8 v1.1 Update (See Note)

Apple 2009-08-31 Mac OS X Server 10.5.8 v1.1 Combo Update (See Note)

Novell SUSE 2009:6392 OpenEXR security update for SLE 10 SP2 i586


Last Updated: 27 May 2016 10:53:40