Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-2582

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2009-2582
Last Modified 31 Jul 2009 01:26:42
Published 23 Jul 2009 04:30:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-2582

Summary

Stack-based buffer overflow in manager.exe in Akamai Download Manager (aka DLM or dlmanager) before 2.2.4.8 allows remote web servers to execute arbitrary code via a malformed HTTP response during a Redswoosh download, a different vulnerability than CVE-2007-1891 and CVE-2007-1892.

Vulnerable Systems

Application

  • Akamai Technologies Download Manager 2.0.4.4

  • Akamai Technologies Download Manager 2.2.0.0

  • Akamai Technologies Download Manager 2.2.1.0

  • Akamai Technologies Download Manager 2.2.3.5

  • Akamai Technologies Download Manager 2.2.3.6

  • Akamai Technologies Download Manager 2.2.4.3


References

VUPEN - ADV-2009-1985

BID - 35778

BUGTRAQ - 20090722 Akamai Technologies Security Advisory 2009-0001 (Download Manager)

IDEFENSE - 20090722 Akamai Download Manager Stack Buffer Overflow Vulnerability

SECTRACK - 1022592

CONFIRM - http://www.akamai.com/html/support/security.html

SECUNIA - 35951


Last Updated: 27 May 2016 10:50:58