Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-3009

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2009-3009
Last Modified 06 Jul 2012 01:10:37
Published 08 Sep 2009 02:30:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-3009

Summary

Cross-site scripting (XSS) vulnerability in Ruby on Rails 2.x before 2.2.3, and 2.3.x before 2.3.4, allows remote attackers to inject arbitrary web script or HTML by placing malformed Unicode strings into a form helper.

Vulnerable Systems

Application

  • Ruby On Rails 2.0.0

  • Ruby On Rails 2.0.1

  • Ruby On Rails 2.0.2

  • Ruby On Rails 2.0.4

  • Ruby On Rails 2.1

  • Ruby On Rails 2.1.0

  • Ruby On Rails 2.1.1

  • Ruby On Rails 2.2.2

  • Ruby On Rails 2.3.2

  • Ruby On Rails 2.3.3

  • Rubyonrails Ruby On Rails 2.0.0

  • Rubyonrails Ruby On Rails 2.0.1

  • Rubyonrails Ruby On Rails 2.0.2

  • Rubyonrails Ruby On Rails 2.0.4

  • Rubyonrails Ruby On Rails 2.1

  • Rubyonrails Ruby On Rails 2.1.0

  • Rubyonrails Ruby On Rails 2.1.1

  • Rubyonrails Ruby On Rails 2.1.2

  • Rubyonrails Ruby On Rails 2.2.0

  • Rubyonrails Ruby On Rails 2.2.1

  • Rubyonrails Ruby On Rails 2.2.2

  • Rubyonrails Ruby On Rails 2.3.2

  • Rubyonrails Ruby On Rails 2.3.3


References

VUPEN - ADV-2009-2544

SECTRACK - 1022824

MLIST - [rubyonrails-security] 20090904 XSS Vulnerability in Ruby on Rails

XF - rubyonrails-unicode-xss(53036)

BID - 36278

OSVDB - 57666

DEBIAN - DSA-1887

CONFIRM - http://weblog.rubyonrails.org/2009/9/4/xss-vulnerability-in-ruby-on-rails

CONFIRM - http://support.apple.com/kb/HT4077

SECUNIA - 36717

SECUNIA - 36600

SUSE - SUSE-SR:2009:017

APPLE - APPLE-SA-2010-03-29-1

CONFIRM - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545063


Last Updated: 27 May 2016 10:57:33