Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-3085

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2009-3085
Last Modified 21 Aug 2010 01:35:11
Published 08 Sep 2009 02:30:00
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2009-3085

Summary

The XMPP protocol plugin in libpurple in Pidgin before 2.6.2 does not properly handle an error IQ stanza during an attempted fetch of a custom smiley, which allows remote attackers to cause a denial of service (application crash) via XHTML-IM content with cid: images.

Vulnerable Systems

Application

  • Pidgin 2.0.0

  • Pidgin 2.0.1

  • Pidgin 2.0.2

  • Pidgin 2.1.0

  • Pidgin 2.1.1

  • Pidgin 2.2.0

  • Pidgin 2.2.1

  • Pidgin 2.2.2

  • Pidgin 2.3.0

  • Pidgin 2.3.1

  • Pidgin 2.4.0

  • Pidgin 2.4.1

  • Pidgin 2.4.2

  • Pidgin 2.4.3

  • Pidgin 2.5.0

  • Pidgin 2.5.1

  • Pidgin 2.5.2

  • Pidgin 2.5.3

  • Pidgin 2.5.4

  • Pidgin 2.5.5

  • Pidgin 2.5.6

  • Pidgin 2.5.7

  • Pidgin 2.5.8

  • Pidgin 2.5.9

  • Pidgin 2.6.0

  • Pidgin 2.6.1

  • Pidgin Libpurple


References

CONFIRM - http://www.pidgin.im/news/security/index.php?id=37

CONFIRM - http://developer.pidgin.im/viewmtn/revision/info/fd5955618eddcd84d522b30ff11102f9601f38c8

BID - 36277

SECUNIA - 36601

Related Patches

Novell SUSE 2009:1604 finch security update for SLE 11 x86_64


Last Updated: 27 May 2016 10:51:07