Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2009-3490

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2009-3490
Last Modified 21 Aug 2010 01:35:55
Published 30 Sep 2009 11:30:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2009-3490

Summary

GNU Wget before 1.12 does not properly handle a '\0' character in a domain name in the Common Name field of an X.509 certificate, which allows man-in-the-middle remote attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.

Vulnerable Systems

Application

  • Gnu Wget 1.10

  • Gnu Wget 1.10.1

  • Gnu Wget 1.10.2

  • Gnu Wget 1.11

  • Gnu Wget 1.11.1

  • Gnu Wget 1.11.2

  • Gnu Wget 1.11.3

  • Gnu Wget 1.11.4

  • Gnu Wget 1.5.3

  • Gnu Wget 1.6

  • Gnu Wget 1.7

  • Gnu Wget 1.7.1

  • Gnu Wget 1.8

  • Gnu Wget 1.8.1

  • Gnu Wget 1.9

  • Gnu Wget 1.9.1


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=520454

VUPEN - ADV-2009-2498

BID - 36205

SECUNIA - 36540

MLIST - [bug-wget] 20090922 Release: GNU Wget 1.12

MLIST - [oss-security] 20090923 Re: More CVE-2009-2408 like issues

MLIST - [oss-security] 20090903 More CVE-2009-2408 like issues

CONFIRM - http://hg.addictivecode.org/wget/mainline/rev/1eab157d3be7

MLIST - [wget-notify] 20090805 [bug #27183] Wget likely suffers from the \0 SSL cert vulnerability


Last Updated: 27 May 2016 10:51:16