Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-7262

Overview

Vulnerability Score 6.5 6.5
CVE Id CVE-2008-7262
Last Modified 20 Oct 2010 12:00:00
Published 19 Oct 2010 04:00:02
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2008-7262

Summary

Multiple directory traversal vulnerabilities in FTPServer.py in pyftpdlib before 0.3.0 allow remote authenticated users to access arbitrary files and directories via vectors involving a symlink in a pathname to a (1) CWD, (2) DELE, (3) STOR, or (4) RETR command.

Vulnerable Systems

Application

  • G.rodola Pyftpdlib 0.1

  • G.rodola Pyftpdlib 0.1.1

  • G.rodola Pyftpdlib 0.2.0


References

CONFIRM - http://code.google.com/p/pyftpdlib/source/browse/trunk/HISTORY

CONFIRM - http://code.google.com/p/pyftpdlib/issues/detail?id=55


Last Updated: 27 May 2016 10:49:31