Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2008-7263

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2008-7263
Last Modified 20 Oct 2010 12:00:00
Published 19 Oct 2010 04:00:02
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2008-7263

Summary

ftpserver.py in pyftpdlib before 0.5.0 does not delay its response after receiving an invalid login attempt, which makes it easier for remote attackers to obtain access via a brute-force attack.

Vulnerable Systems

Application

  • G.rodola Pyftpdlib 0.1

  • G.rodola Pyftpdlib 0.1.1

  • G.rodola Pyftpdlib 0.2.0

  • G.rodola Pyftpdlib 0.3.0

  • G.rodola Pyftpdlib 0.4.0


References

CONFIRM - http://code.google.com/p/pyftpdlib/source/diff?spec=svn348&r=348&format=side&path=/trunk/pyftpdlib/ftpserver.py

CONFIRM - http://code.google.com/p/pyftpdlib/source/detail?r=348

CONFIRM - http://code.google.com/p/pyftpdlib/source/browse/trunk/HISTORY

CONFIRM - http://code.google.com/p/pyftpdlib/issues/detail?id=73


Last Updated: 27 May 2016 10:49:31