Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-0216

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2011-0216
Last Modified 06 Feb 2013 11:40:19
Published 21 Jul 2011 07:55:01
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-0216

Summary

Off-by-one error in libxml in Apple Safari before 5.0.6 allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow and application crash) via a crafted web site.

Vulnerable Systems

Application

  • Apple Safari 1.0

  • Apple Safari 1.0.0

  • Apple Safari 1.0.0b1

  • Apple Safari 1.0.0b2

  • Apple Safari 1.0.1

  • Apple Safari 1.0.2

  • Apple Safari 1.0.3

  • Apple Safari 1.1

  • Apple Safari 1.1.0

  • Apple Safari 1.1.1

  • Apple Safari 1.2

  • Apple Safari 1.2.0

  • Apple Safari 1.2.1

  • Apple Safari 1.2.2

  • Apple Safari 1.2.3

  • Apple Safari 1.2.4

  • Apple Safari 1.2.5

  • Apple Safari 1.3

  • Apple Safari 1.3.0

  • Apple Safari 1.3.1

  • Apple Safari 1.3.2

  • Apple Safari 2

  • Apple Safari 2.0

  • Apple Safari 2.0.0

  • Apple Safari 2.0.1

  • Apple Safari 2.0.2

  • Apple Safari 2.0.3

  • Apple Safari 2.0.4

  • Apple Safari 3

  • Apple Safari 3.0

  • Apple Safari 3.0.0

  • Apple Safari 3.0.0b

  • Apple Safari 3.0.1

  • Apple Safari 3.0.1b

  • Apple Safari 3.0.2

  • Apple Safari 3.0.2b

  • Apple Safari 3.0.3

  • Apple Safari 3.0.3b

  • Apple Safari 3.0.4

  • Apple Safari 3.0.4b

  • Apple Safari 3.1.0

  • Apple Safari 3.1.0b

  • Apple Safari 3.1.1

  • Apple Safari 3.1.2

  • Apple Safari 3.2.0

  • Apple Safari 3.2.1

  • Apple Safari 3.2.2

  • Apple Safari 4.1

  • Apple Safari 4.1.1

  • Apple Safari 4.1.2

  • Apple Safari 5.0

  • Apple Safari 5.0.1

  • Apple Safari 5.0.2

  • Apple Safari 5.0.3

  • Apple Safari 5.0.4

  • Apple Safari 5.0.5


References

APPLE - APPLE-SA-2011-07-20-1

CONFIRM - http://support.apple.com/kb/HT5001

CONFIRM - http://support.apple.com/kb/HT4999

CONFIRM - http://support.apple.com/kb/HT4808

APPLE - APPLE-SA-2011-10-12-2

APPLE - APPLE-SA-2011-10-12-1

REDHAT - RHSA-2011:1749

MANDRIVA - MDVSA-2011:188

DEBIAN - DSA-2394

REDHAT - RHSA-2013:0217

Related Patches

Red Hat 2012:0016-01 RHSA Important: libxml2 security update for RHEL 4 x86

Red Hat 2012:0016-01 RHSA Important: libxml2 security update for RHEL 4 x86_64

Red Hat 2012:0017-01 RHSA Important: libxml2 security update for RHEL 5 x86

Red Hat 2012:0017-01 RHSA Important: libxml2 security update for RHEL 5 x86_64


Last Updated: 27 May 2016 10:58:03