Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-0771

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2011-0771
Last Modified 26 Jul 2012 12:00:00
Published 03 Feb 2011 08:00:08
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-0771

Summary

The Janrain Engage (formerly RPX) module 6.x-1.3 for Drupal does not validate the file for a profile image, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks and possibly execute arbitrary PHP code by causing a crafted avatar to be downloaded from an external login provider site.

Vulnerable Systems

Application

  • Janrain Engage Module 6.x-1.3

  • Janrain Rpx 6.x-1.3


References

BID - 45926

CONFIRM - http://drupal.org/node/1033154

XF - janrain-file-upload(64848)

XF - janrain-unspecified-xss(64847)

SECUNIA - 42980

OSVDB - 70623


Last Updated: 27 May 2016 10:54:57